Брешь в Apache позволяла получить root-привилегии с помощью скрипта

Брешь в Apache позволяла получить root-привилегии с помощью скрипта

Уязвимость повышения привилегий затрагивает Apache HTTP-сервер — пользователи, имеющиеся право записи и запуска скриптов, могли получить root-привилегии в системах Unix. Проблема актуальна для версий Apache с 2.4.17 по 2.4.38, а с выпуском Apache 2.4.39 ее устранили.

Уязвимость, получившую идентификатор CVE-2019-0211, обнаружил эксперт Чарльз Фол. Представители Apache прокомментировали ситуацию следующим образом:

 

«В релизах линейки Apache HTTP Server 2.4 (2.4.17 — 2.4.38) можно выполнить произвольный код с привилегиями родительского процесса (как правило, это root). Этого можно добиться за счет манипуляции scoreboard. Кроме Unix-систем все остальные системы не затронуты данной брешью».

CVE-2019-0211 наиболее опасна в том случае, когда пользователи с ограниченными правами могут получить root-привилегии, запуская скрипты и команды на уязвимом сервере.

Чарльз Фол отметил, что предоставлять пользователям с низкими привилегиями возможность записывать собственные скрипты — довольно распространенная практика.

Источник: www.anti-malware.ru

 

ОСТАВЬТЕ ОТВЕТ

Пожалуйста, введите свой комментарий!
Пожалуйста, введите свое имя здесь